Windows環境でcompassの最新版をインストールしたら...

最新版のcompassをインストール、環境を構築していざ開発を進めようとしたら、下記のエラーメッセージが表示され、cssファイルがコンパイルされませんでした。
Rubyコマンドプロンプトを管理者権限で開かないとだめなのかな?と思いやってみたけど、同じエラーを吐くのでそういうことではないみたい。

overwrite stylesheets/style.css
Errno::EACCES on line ["903"] of C: Permission denied - (Z:/v1302/560days/styles
heets/style.css20140417-6064-1pgki0n, Z:/v1302/560days/stylesheets/style.css)
Run with --trace to see the full backtrace

Googleで調べた結果、下記のAnswersの方法でとりあえずは解決できました...。

"Errno::EACCESS...permission denied" running compass watch

インストールされているsassとcompassを削除して、バージョンを指定してインストール。

gem uninstall compass
gem uninstall sass
gem install sass --version "3.2.10"
gem install compass --version "0.12.2"

バージョンダウンする羽目になってしまいましたが、これで無事動いてくれるようになりましたとさ...。そのうち解消されるのかな?

投稿日
カテゴリ