CentOS4.8にCPAN2をインストール

CentOS4.8にCPAN2をインストールしようとしたら下のエラーを返されました。

エラー: Failed dependencies:
rpm-build is needed by cpan2rpm-2.027-1.noarch
Suggested resolutions:
/home/buildcentos/CENTOS/en/4.0/i386/CentOS/RPMS/rpm-build-4.3.3-32_nonptl.i386.rpm

これはCentOS5.xのときにも経験しましたが、「rpm-build は cpan2rpm-2.027-1.noarch に必要とされています」   ってことだと思うので、一旦「# yum install rpm-build 」でrpm-buildをインストール後再度実行したところCPAN2のインストールが無事完了しました。

自分用備忘録もそれなりに役に立つと実感しました。
投稿日
カテゴリ