PostTweetをバージョンアップ

ブログ投稿とtwitterへのツイートをPostTweetプラグインで連携させているのですが、TwitterAPIv1.0の提供が終了した影響か機能しなくなっていました。

検索してみるとTwitterAPIv1.1に対応したPostTweet1.0.0がリリースされていたのでさっそくインストールしてみたのですが、モジュールが読み込めない旨のエラーメッセージが表示されてしまいました...。 エラーメッセージ

はぁ...面倒だなぁと思いながらも関連モジュールをインストールすることに。

「設定画面を見るとお使いのサーバーで必要なモジュールをよみこめません:Net::OAuth::Simple」とあったのでまずは「perl-Net-OAuth-Simple-1.1-1.noarch.rpm」をダウンロードしてインストールしようとしたら 「Net::OAuth」が無いと怒られてしまいました...。

# wget http://rpm.mag-sol.com/Centos/5/x86_64/perl-Net-OAuth-Simple-1.1-1.noarch.rpm
# rpm -Uvh perl-Net-OAuth-Simple-1.1-1.noarch.rpm
perl(Net::OAuth) は perl-Net-OAuth-Simple-1.1-1.noarch に必要とされています

で「perl-Net-OAuth-0.27-1.noarch.rpm」をダウンロードしてインストールしようとしたらさらにモジュールが足りないと怒られてしまいました...。

# wget http://rpm.mag-sol.com/Centos/5/x86_64/perl-Net-OAuth-0.27-1.noarch.rpm
# rpm -Uvh perl-Net-OAuth-0.27-1.noarch.rpm
perl(Class::Accessor) >= 0.31 は perl-Net-OAuth-0.27-1.noarch に必要とされています
perl(Class::Data::Inheritable) >= 0.06 は perl-Net-OAuth-0.27-1.noarch に必要とされています
perl(Digest::HMAC_SHA1) >= 1.01 は perl-Net-OAuth-0.27-1.noarch に必要とされています
perl(Digest::SHA1) >= 2.12 は perl-Net-OAuth-0.27-1.noarch に必要とされています

しょうがないので必要なモジュールをダウンロードしてインストールしました。

Class::Accessor

# wget http://pkgs.repoforge.org/perl-Class-Accessor/perl-Class-Accessor-0.34-1.el5.rf.noarch.rpm
# rpm -Uvh perl-Class-Accessor-0.34-1.el5.rf.noarch.rpm

Class::Data::Inheritable

# wget http://pkgs.repoforge.org/perl-Class-Data-Inheritable/perl-Class-Data-Inheritable-0.08-1.el5.rf.noarch.rpm
# rpm -Uvh perl-Class-Data-Inheritable-0.08-1.el5.rf.noarch.rpm

Digest::HMAC_SHA1

# wget http://rpm.pbone.net/index.php3/stat/4/idpl/19922105/dir/centos_5/com/perl-Digest-HMAC-1.01-15.noarch.rpm.html
# rpm -Uvh perl-Digest-HMAC-1.01-15.noarch.rpm.html

Digest::SHA1

# wget http://pkgs.repoforge.org/perl-Digest-SHA1/perl-Digest-SHA1-2.13-1.el5.rfx.x86_64.rpm
# rpm -Uvh perl-Digest-SHA1-2.13-1.el5.rfx.x86_64.rpm

必要なモジュールをすべてインストールした後再度「Net::OAuth::Simple」をインストール。今度は怒られなかったのでこれで動くようになっただろうとおもったら、今度は「Net::OAuth::Simple」が読み込めない旨のエラーメッセージが表示されてしまいました...。
再度提供元のサイトをよくよくみたら最新バージョンPostTweet-1.1.3がリリースされていたのでこれをインストールして認証しようとしたら、これはこれで認証ダイアログ画面でエラーを吐いてしまいました...。
そこで試しに1つ前のバージョンPostTweet-1.1.1をインストールしてみたら認証できました。twitterへの連携も上手くいっているようです。

投稿日
カテゴリ